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SOFTWARE INSTALLATION

The GEC PinPoint Monitor software is designed to run on Windows NT,
Windows 2000, or Windows XP. Most of the software features will function
normally under W95, W98, or Windows ME, but these operating systems are no
longer being supported.

The software will also run under Windows Vista, but with reduced performance.
To avoid intermittent program lockup when running on Vista, go to the Task
Manager, open the Processes Tab, highlight PPMonitor.exe, right click, and set the
priority to Above Normal. This operation must be performed each time you restart
PPM on Vista.

System requirements are 128k of memory and a 500Hz or higher processor.
Four programs are provided with your GEC instrument:
PinPoint Monitor (PPM) is the main program used for display, plotting and logging

of temperatures and/or other inputs (such as relative humidity) that are available in
your hardware.

PinPoint Settings (PPS) is used to set the Com Port, the default temperature units,
and the configuration file for PPM. Com Port entry is a text field to allow for
custom or higher numbered Com Ports.

PinPoint Viewer (PPV) is used to view and export data from logged files.

PinPoint Parser (PPP) is used to create new configuration files for your instrument,
but with fewer channels than the full configuration. This enables faster scanning.

IMPORTANT: If you have a previous PPM version installed on your computer,
you must remove this version before installing a new version. First go to
Settings—> Control Panel->Add/Remove Programs. Then Remove PinPoint
Monitor. If you get the message "Remove Shared File?", click Yes to All. And
respond Yes you wish to proceed.

The software is provided in a self extracting installer: PPM Install.exe. Double
click on this file to install the software on your computer. The install will place
icons on the desktop for PPM, PPS, PPV, and PPP. It will also provide a shortcut
to PPM Readme.txt, which is a file to get you started with the software.
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HARDWARE FILES

Important files particular to your hardware are in a second self extracting file
named: <your serial number> install.exe. These files must be installed after PPM
Is installed. To install these files just click on the “<your serial number>
install.exe”. Click through Next, and Finish.

The hardware files will be installed to a folder with the same name as the Serial
Number of your hardware. They will appear on your hard drive at C:\Program
Files\GEC\PinPoint\<serial number>.

Should these files become corrupted while running PPM, they can be restored from
the self-extracting hardware install file.

RUNNING THE SOFTWARE

The default Com Port is Com 1. Default temperature units are °C. Run PinPoint
Settings if you wish to change either of these settings. Select your desired settings,
click OK and then answer Yes to "Apply New Settings".

If your installation is complete and if your hardware is powered up and connected
to COML, (or to another Com Port selected in PPS) you should be able to start the
PinPoint Monitor program and begin taking readings. The first time you run the
program it will automatically ask you to create a new workspace name (*.ppw) and
a new input monitor name (*.ppi). If no readings appear, go to
TROUBLESHOOTING PROCEDURES on page 20.

When you start PPM, the program communicates with the instrument through the
serial port and tells it to start sending data. The instrument will then start sending
data continuously until you exit PPM.

The instrument operates in scanning mode. Once it is started, it sends the data
from all channels on a continuous basis over the serial port whether or not you
have a sensor connected to every channel. The scan interval is the update interval
for your data.

While the program is running, the most recently sent data are displayed in the
Real-Time Report, which is located at the left side of the screen upon program
startup. These are the current temperatures and they are updated at the scan
interval.
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The Real-Time Graph is to the right of the Real-Time Report. This graph plots the
temperatures, one or more pixels at a time. It starts plotting automatically as soon
as the program is started. The number of pixels available for the plot depends on
the size of your window and the resolution that you have set for the display. This
plot is Optimized automatically on startup by scaling the time for the X- Axis so
that each new data point in the plot is equivalent to one pixel.

THE MENU BAR

Many program features are controlled from the Menu Bar located at the top of the
main window.

File: This menu provides the standard Windows file open and save features, as
well as commands to perform on the active document and on the workspace. The
bottom of this menu contains a recent file list, any of which can be opened by
clicking on the file name.

View: This menu toggles which toolbars and windows should be displayed.
Tools: This menu gives access to additional tools, including Alarm Settings, the
Calibration Wizard, Copy Real-Time Report, Configure Differential

Thermocouples, and Program Startup Options.

Windows: This menu provides capability for arranging and sizing the various
windows of the application.

Help: This menu accesses the built in Help system for PinPoint Monitor. You
must have an IE browser on your computer to open the PPM Help file.

THE MAIN TOOLBAR
The Main Toolbar provides a convenient and visual way to access the functionality

of the Menu items. As you move the mouse pointer over each icon, a descriptive
panel will appear for that item.

New Workspace: The leftmost icon is used to create a new workspace, *.ppw.
Each time the PPM program starts you must create a new workspace or load a
previous workspace. A previous workspace will automatically be loaded on
program startup if this option is selected. PPM can have only one workspace at
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any given time. If you change the default temperature units within PinPoint
Settings (PPS), then you must not try to load a previous workspace created with
different units.

New Input Monitor: The next icon is used to create a new input monitor view,
*.ppi. Please note that you may create multiple ppi views, each with its own
selected channels and graph settings.

New Log Manager: Use this icon to create a log manager, *.ppl which will keep
track of the details of your log files.

Togale Workspace: Click this icon to open or close the Workspace. The
Workspace is a main component of PinPoint Monitor. It manages views, logs,
calibration files and hardware settings. Normally the workspace will be closed.

Toqgagle Device Status: Click this icon to open or close the Device Status window.
This window reports the actions of the hardware components. Normally this
window will be closed except when diagnosing a problem with the operation of the
hardware. If the hardware is functioning properly, its operation will be transparent
to the user.

Switch to Input Monitor: Click this icon to bring the input view (*.ppi) containing
the real-time readings and the plot to the front. Multiple clicks will cycle through
all input monitors (*.ppi) if more than one is loaded in the workspace.

Switch to Log Manager: Click this icon to bring the log manager to the front.
Multiple clicks will cycle through all log managers if more than one is loaded in
the workspace.

THE STATUS BAR

The Status Bar at the bottom of the screen indicates the connection port, the mode
(normal or simulation), the scan interval, the configuration file (*.ppc), the
calibration file (*.cal), the hardware file (*.pph), and it shows how many logs are
active.
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THE REAL-TIME REPORT

When the program starts up, the temperatures from all channels are displayed and
updated at the scan interval in a dockable window at the left of the screen. This
window may be moved to a different position if desired. Channels with sensors
not plugged in or not working will display as OPEN. Note that the size of the
windows in Pinpoint Monitor can be adjusted vertically or horizontally by moving
the mouse pointer to the border of the window (a double edged arrow will pop up),
and then dragging the border to make the window larger or smaller.

You may grab the right border of the Real-Time Report with the mouse pointer and
move it to the right. This will reveal additional headings for Units and for Time
Stamp. The Units column is used to display current units for each input. To
change units for any channel, click anywhere on the line for that input. Then
double click on the name of the unit. A box will open with the name of the
available units. Click the desired unit, then click anywhere in the report to update
your selection. Note that you can change the width of any column in the Real-
Time Report by grabbing the interface between column headings with the mouse
pointer and moving left or right.

The Options Dialog (Tools Menu - Options) allows you to configure the
precision of thermocouple and thermistor readings that appear in the Real-Time
Report. The defaults are two decimal places for thermocouple probes and four
decimal places for thermistor probes. If you change these settings, they are saved
to the registry and reloaded the next time you start the program. NOTE: These
settings do not affect graphing or logging.

The Aliases

The labels under the Input heading are in the form of aliases. That is, the user can
edit these labels to provide a more meaningful description of what that input
represents. For example if a label reads TC1, this means thermocouple number 1.
But if thermocouple number 1 is in the center of a seed, you may wish to change
the TC1 label to read Center of Seed. Just click on that line, double click on the
label, and when you get a blinking cursor you can edit the label. Then click
anywhere in the report to update the label.

It is advantageous to keep the aliases to as few characters as possible because the
Aliases you enter will subsequently appear elsewhere in the program such as graph
labels, and channel labels for logging and exporting data.
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Once you have edited the Aliases, you may wish to save this custom input view
with File >Save All. The Aliases and the default units for each input are saved in
the workspace file *.ppw. You are allowed to have more than one file with this
extension, but only one *.ppw may be loaded at a time. If you wish to save
different Views with different aliases or different units you should create a new
workspace prior to editing the Aliases or editing the units, then save the
workspace.

If you are going to edit the Aliases, you must do so before creating a log file. Once
you have created a log file within a given workspace, you will not be able to edit
the aliases while that log is active. If no logs are active, then you can edit or re-
edit aliases.

THE REALTIME GRAPH

The right portion of the screen contains the Real-Time Graph. Channels to be
plotted can be toggled on or off individually by moving the mouse pointer and
clicking the box to the left of the channel ID. You may click on one or more boxes
to turn those channels on or off as desired. Do not be concerned if the software
does not respond immediately to your clicks on these boxes. Sometimes they will
not be updated until the beginning of the new scan, i.e. you may have to wait all or
part of a scan interval to see a response to your mouse clicks on these boxes.

The background of a box will be white whenever a channel is turned off. When it
Is turned on for plotting, the box will have a color representing the color of the
graph for that channel. Clicking the box in the header toggles all channels on or
off. At least one channel will be on at all times.

The elapsed time of the Real-Time Graph is displayed in a bar above the graph.
This bar also includes the current time from the clock on your computer. Clicking
Reset will restart the Real-Time Graph.

Y-Axis Settings is used to select the scale for the Y Axis.

X-AXis Settings provides a window to select X Axis plotting options for the Real-
Time Graph. Click Optimize to automatically select a page size that will be scaled
such that each new incoming data point will be plotted at the next pixel on the

graph. The time units on the Real-Time Graph may be in days, hours, minutes, or
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seconds. Please refer to the section REALTIME GRAPH PLOTTING OPTIONS
for further information on plotting features.

Unit is used to select the units for the Y-Axis. If your system includes multiple
types of units such as temperature and relative humidity, you can only select one
type of units for a particular Real-Time Graph. If you desire to see Real-Time
plots for more than one unit, simply create another input monitor (*.ppi) and select
the desired units. Each time you select different units in a given *.ppi, the Real-
Time plot will be restarted automatically.

DATA LOGGING

If you want permanent data that can’t be lost accidentally, then you should start a
log as soon as you start the program. Do not rely solely on the Real-Time Graph to
save important data. Log all channels of importance at whatever interval is
needed.

PinPoint Monitor logs selected channels to a database (*.ppd). Any or all channels
may be selected for logging at user specified time intervals. Logged data may later
be retrieved from the database by exporting to another file format such as Excel.

Before logging can begin for the first time, you must create a new log manager.
Click on the third Icon in the Main Toolbar [New Log Manager]. Give the log
manager file a name. It will have extension *.ppl. Click Ok and the log manager
view will be displayed. This is basically an organizational table that will show the
details of the log sessions that you have created.

To add a log session to the log manager, click on Edit >New Log. Enter a
filename for the log and click on Save. A window will pop up to enable selecting
which channels to the log as well as the log interval and the log mode. Select or
deselect all channels by clicking the box at the top of the window.

The log mode can be Timed or Direct. Direct mode logs every reading of the
hardware by automatically selecting a time interval equal to the scan interval. In
Timed mode, select the desired time units for the log interval from the drop-down
menu, and enter the desired time for the log interval, with or without a decimal
point as desired.
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The default units for logging will be those in the Real-Time Report. If you wish to
log in different units, click on the unit name and select other units. These must be
edited channel by channel.

Select ‘Instantaneous’ to log data from the selected channels at the time interval
selected. You may also select parameters to log statistical data including average,
standard deviation, maximum, minimum and spread.

When you have finished making your selections, click Ok.

Note that a new line is added to the log manager. The number of channels in the
log appears in the second column. Note that the Time Interval and the Log File
name are shown at the right hand side of the line. If you wish to add a description
to the log, click under Description and edit <unnamed log>.

Click on the box at the left of the experiment line to manually start the log session.
Or you may right click anywhere on the line to open a dialog that will enable you
to select a date and time to start logging later. If you select a delayed start time
that is prior to the current real time, the log will start as soon as you close this
window. You may also select a date and time for the log to stop. The log session
will continue as long as the program is running and the box at the left of the line is
checked. You may toggle this log session on and off at any time with this check
box.

Note that the time that the log was started is automatically displayed. Unless you
have selected a time for the log to stop, the end time is listed as <...active...>
whenever the log is running. If the logging is stopped, the end time of the log will
be automatically displayed.

If you wish to later view which channels have been selected for logging in a
particular session, highlight that session, and double click anywhere to the right of
the checkbox. You may also use the “View Log Settings” option under the Tools
menu to see details of a particular log after it has been created.

You may add other log sessions to the log manager as desired. These may contain
the same or different channels and the same or different log intervals as previously
created log sessions. And you may have several log sessions running
simultaneously if desired. Note that it is not possible to have multiple log sessions
using the same database (*.ppd) simultaneously. You should turn off log sessions
before exiting PPM.
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Note that you may wish to create new log managers (*.ppl) for different users or
different projects.

RETRIEVING DATA FROM A PPM DATABASE

Data may be retrieved from a PPM database at any time by exporting to another
file format for permanent storage. And logged data in a PPM database may be
viewed or exported at any time by running the stand alone PinPoint Viewer
program described on page 23 of this document.

To export data from within PPM, first open the log file window, *.ppl. Then select
the line for the log session from which you wish to retrieve data. The log session
is selected by clicking anywhere on the line. This log session will be highlighted.
To export data from this log session to a permanent file, click on Tools > Export
Log. This will open a window in which you will select the channels for which you
wish to export data. The window’s title bar will show the number of entries in this
log. Click in the box at the top of the window to select or deselect all channels. If
you do not wish to export all channels, click on those you want to export.

Exporting will retrieve every data point logged for the time period within the Start
Time and End Time. Note that the beginning and end time of the log session are
automatically inserted. If you do not wish to export all the data, you may edit the
Start Time and or the End Time before exporting. If you wish to export all the
data, simply make sure that the Start Time is less than or equal to the begin time of
the log and that the End Time is equal to or greater than the end time of the log.

Note that you may edit the Description field if you wish, up to a maximum of 32
characters. Valid characters include only letters and numerals. Or you may leave
the name of the Description field blank.

You may select the type of file to export to, including a spreadsheet file, HTML
document, or text file.

Under Location, you must enter a filename to export the data to. The export will
have a time stamp in the format Month/Date/Year HH:MM:SS. Further, you may
select an additional column of elapsed time starting with O for the first data point.
Units for the elapsed time may also be selected. And if you do not want all the
readings, you may enter an integer number in the Filter. Once all selections have
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been made, click Ok and the export will begin. An hourglass will appear during
the export process.

Sometimes when exporting to Excel, you may get the message: Can't Update.
Database or object is read-only. [If you get this message, then usually it will work
correctly if you try it a second time.

The message: Can't Update. Database or object is read-only sometimes occurs
when the ppd file is saved in a path that is over 64 characters in length. It only
appears intermittently. In order to avoid this error, try to keep path names to less
than 64 characters. (For example, “C:\data\filename.ppd” instead of
“C:\data\folder\second folder\third folder\fourth folder\fifth folder\filename.ppd”)

Keep in mind that path names to My Documents or the Desktop are longer than
“My Documents\File name” or “Desktop\File name” (The real path is to My
Documents is “C:\Documents and Settings\<user>\My Documents\File
name.ppd.”)

Note that the upon opening a standard Excel spreadsheet, the time stamp in the first
column will appear as MM:DD:YY. The seconds will appear to be missing. This
behavior is standard Excel behavior. The HH:MM:SS units are there, but in order
for them to appear, first the column must be reformatted with Format - Cells >
Number - Custom. Under Type, pick m/d/yyyy h:.mm. Then add :ss and click
Ok.

HARDWARE SETTINGS

You may edit hardware settings by opening the Workspace and double clicking on
Hardware 0. This will open the Hardware Configuration dialog. You may edit the
COM port, the baud, data averaging, filter (this is a low pass filter), and data rate.
Choose a data rate of 60, 30, 15, 12 or 10 to reject 60 Hz noise (or 50, 25, 16.6667,
12.5 or 10 in areas with 50Hz power). Note that the available scan interval range
(min. to max.) automatically updates as you change other parameters. For any
combination of parameters, the default scan interval shown is the same as the
minimum scan interval. If you wish to receive the readings from the instrument at
a different interval, you can enter any desired scan interval (in units of seconds)
within the available range shown. You may save these new settings under a new
filename with a .pph extension. If you do not save the settings manually, they will
automatically be saved in a file called “new_settings.pph” when you press OK to
leave the Hardware Configuration dialog. Note this file will be added to the
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workspace, which means it will be automatically reloaded whenever this
workspace is loaded.

CALIBRATION PROCEDURE

The GEC Instruments system uses unique hardware and software procedures to
enable very stable and highly accurate temperature measurements. The unit has
been carefully calibrated prior to delivery. However, the user may wish to
calibrate the entire system, including user-installed thermocouples, to provide the
utmost accuracy available from the equipment. Please refer to the Hardware
manual for your particular instrument for guidance on how to accomplish a good
calibration. If your instrument has inputs in addition to temperature, such as
relative humidity, you may use the calibration procedure within PPM to calibrate
these inputs also. If you are calibrating an instrument with multiple types of inputs
(such as temperature and humidity), be sure to select only one type of input at a
time during a calibration.

The thermocouple calibration procedure involves generating a set of correction
factors for each thermocouple channel and storing these in a calibration file, *.cal.
If a one point calibration is performed, this file will contain a list of temperature
offsets which will be applied to those channels which were calibrated. If a two
point calibration is performed, the *.cal file will contain a list of slopes and offsets
which will automatically be applied to those channels that were calibrated. If the
user wishes extreme accuracy in a particular range, the system should be calibrated
with a two point calibration at two temperatures near the ends of the range of
interest.

A new calibration file *.cal is created and loaded into PinPoint Monitor whenever
you calibrate thermocouples. If a mistake is made during calibration, you can hit
the back button within the calibration Wizard. And you can always go back and
recover a previous calibration.

To start a calibration from within PPM, click on Tools = Calibration Wizard. This
will open a dialog (Calibration Wizard: Step One) where you can select a one point
or a two point calibration. Or if you wish to load an existing calibration file, select
Load User Calibration, and click on a filename under User Calibrations.

Now select the temperature units of the reference device that you are using to
calibrate against. These units do not have to be the same as the units you are using
in PPM, as long as they are the same type of units. That is, you can input readings
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in °F from a standard thermometer even if you are using °C within PPM. If you
are calibrating humidity inputs, select units of percent.

If you are doing a new calibration, you may wish to select one of your existing
thermocouples (or a precision thermistor or RTD probe if your unit has either of
these) to calibrate other thermocouples against. In this instance, choose Use
Reference and then click on the box below to select which input to use as a
reference.

Next you must select the inputs to be calibrated by clicking on the associated boxes
in the input list. Remember that the system may not respond to these clicks until
the end of the scan interval. Click “Next” and go to Step Two: Gather Calibration
Information. Place the probes together with a reference device into a steady
environment. Follow the directions in the dialog. When readings become stable,
enter the value from your reference device into the slot at the lower left. If you are
using an existing thermocouple or other probe connected to your instrument as a
Reference there is no need to enter a value, this probe will be read automatically.

Now click Acquire. If you make a mistake in entering the temperature or if the
readings are not stabilized you can enter a new value and click Acquire again. Or
If you have made wrong selections on the previous screen, you can click the Back
button and make corrections. Once you are satisfied with your readings, click next
to go to Calibration Point number 2 (this point will be skipped if you are doing a
one point calibration).

Repeat the procedures for point two, then click next to go to Final Step:
Calibration. Here you may view the calibration details. Since the details are
selected in blue, you may copy them to the clipboard (Press Ctrl and C) so they
may be imported into a text file for a permanent record.

If you are satisfied with the calibration, press Finish. The calibration corrections
will automatically be applied to your inputs.

Now enter a file name for your new calibration file. You may click on the browse
button at the right to negotiate a new path if desired. Once you have entered the
file name, click Ok and the calibration file will automatically be loaded into the
workspace. The calibration file name will appear in the Status Bar as well.

You may have only one calibration file loaded at a time. If you wish to go back to
the default calibration, open the workspace and highlight the calibration file *.cal.
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Press delete and the *.cal will be removed from the workspace and the default
calibration will be restored.

Be careful when loading previous calibration files, particularly if you are restoring
calibration constants for only some of the inputs and not all of them.

ALARMS

Alarms allow each input probe to be monitored and an arbitrary action can be
triggered whenever some threshold is exceeded. Choosing Alarm Settings from
the Tools menu displays a dialog that gives access to the parameters defining an
alarm and the action to be taken when it is triggered. Each channel may have a
high alarm and a low alarm associated with it. A high alarm activates whenever
the temperature equals or exceeds the high alarm threshold. A low alarm activates
whenever the associated temperature equals or goes below the low alarm threshold.
Alarms may fire once only (the first time the condition is satisfied), or whenever
the condition is true.

An alarm action may be one of "System Beep", "Play Sound", or "Execute
Command"”. System Beep & Play Sound are similar; the difference is that Play
Sound plays an arbitrary .wav file of your choice. Execute Command is a
powerful option, which lets you construct an arbitrary command line using the
parameters of the alarm event. Here are some examples:

cmd /c echo Alarm fired >> C:\AlarmLog.txt

This will append the line "Alarm fired" to the file C:\AlarmLog.txt, whenever the
alarm is triggered. To make available more information about the alarm event, you
may include special %-format specifiers on the command line. Valid substitutions
are:

%% - % character

%t - timestamp

%a - current alias of offending probe

%v - value of offending probe in alarm threshold's units
%r - alarm threshold (including units)

%y - alarm type (Hi or Low)

So, if instead the command were written
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cmd /c echo Alarm fired: input %a exceeded threshold %r at %t >>
C:\AlarmLog.txt

then, every time the alarm is triggered, a line of the form

"Alarm fired: input "REF" exceeded threshold 50 Celsius at 15:23:46 13 February,
2004"

will be written to the end of the file c:\AlarmLog.txt.

CONFIGURING DIFFERENTIAL THERMOCOUPLE INPUTS

Differential thermocouple inputs can be used to read small temperature differences
to very high accuracy. Such inputs read the difference in temperature between two
thermocouples in a circuit where one thermocouple is the reference junction and
the other is the measuring junction. For best accuracy, the approximate
temperature of the cooler side (reference junction) must be known. Choose Config
Differential TC’s from the Tools menu to display a dialog that enables the user to
set the temperature of the cooler side to a fixed value, or to select another probe as
a reference for the cooler temperature. A separate cool side temperature can be set
for each differential thermocouple input. If these values are not set, they are 0 °C
as a default.

CLOSING THE PROGRAM

You may exit PinPoint Monitor with File > EXxit or by clicking on the X at the
upper right of the main window. If any log sessions are active when you attempt to
exit, you will get a message to this effect. You must close these logs to continue
exiting.

THE PPM DYNAMIC DATA EXCHANGE SERVER - DDE
Dynamic Data Exchange (DDE) is a process whereby data can be shared among

multiple Windows programs (including Labview) running on the same computer or
over a network. PinPoint Monitor implements DDE with the DDEML.
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Additional information on this is available online through MSDN. For the DDE
Server to respond, PinPoint Monitor must be running with a *.ppi loaded (i.e. you
must see a Real-Time Report and Real-Time Graph running).

Service Name

Pinpoint registers under the default service name "PPMonitor”. This can be
changed by the user by adding a file called “DDEConfigFile.ppn”, containing the
desired DDE server name and nothing else, to the directory containing the *.ppc
file (the configuration file for your instrument). The ability to register under
different service names is useful when running multiple instances of PPM on the
same computer or the same network.

Topic Names

Pinpoint currently supports two topics: "System™ and a topic named after the
*.ppc file that is loaded. For example, if you are running AHOL.ppc, then there
will be a topic "AHO1.ppc". If you would like to determine this programmatically
at runtime, you can request the item "Topics" from the "System" topic, and it will
return the correct *.ppc name.

Items

Under the relevant .ppc topic, the following items are supported for advise-
loop notification:

"Average Scan Interval”, the scan interval, in seconds

"Probe Names", a comma-separated list of probe names

"Scan Start Time", a timestamp for the beginning of each scan

"Temperatures”, a comma-separated list of current
temperatures

“Temperature Units" the current temperature units
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REALTIME GRAPH PLOTTING OPTIONS

The Real-Time Graph has many optional features that may be set by the user.
Click on the X-axis Settings to edit the time settings for the Real-Time Graph. The
Duration is the total time on the x-axis of the Real-Time Graph. When the plotted
data has reached the end of the graph, values will continue to be updated at the
rightmost side of the graph, and previous values will move to the left at each
update.

The Duration is the time period for which data will be stored in memory. For
example, if the duration is 300 minutes, then the program will store and plot data
for 300 minutes at the update interval shown. The update interval for the Real-
Time Graph is not necessarily the same as the scan interval. Rather it depends on
the number of pixels available in the plot, graph duration, etc. If the Update
Interval indicates "Hardware Limit", then the graph will be updating as frequently
as possible, at the scan interval, which is the same rate as the new data are coming
from the instrument.

A particular chart may be divided into several pages by enabling the scrolling
option and entering the time for each page. Note the update interval shown. If you
click Optimize, the Real-Time Graph will be set up to plot with a density of N
readings per pixel, where N is “Scans per pixel” in the dialog, whenever the
amount of time indicated by the update interval has elapsed. For this reason, there
Is a fixed relation between duration, time length per page and update interval. And
this relation depends on the resolution at which the monitor is operating. The user
cannot set the update interval, however, the user can modify the hardware scan
interval which directly influences the update interval. The update interval is
changed automatically based on the selections made for units, duration, and page
length.

The points being plotted are being saved in memory and the program allocates
about half of the available memory to the Real-Time Graph. If a very long
duration is selected, then the chart will be limited by available memory and the
update interval will be increased accordingly. If multiple input monitors (*.ppi’s)
have been created, the available memory is automatically shared among the
multiple Real-Time graphs.

If the update interval is at the hardware limit, this means that points on the Real-
Time Graph are being plotted as frequently as possible, which is at the same rate as
they are being acquired by the hardware. In this instance the chart may not take up
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the full screen and there may be unused white space to the right of the graph. If
this occurs, increasing the Page value will widen the graph and allow more pixels
to be plotted at the same interval. Click Optimize to do this automatically.

If "Hardware Limit" is grayed out, then the graph will update at an interval that is
more than the scan interval. But remember that the Real-Time Report continues to
update at the scan interval.

As an example, if you set the graph duration to 300 minutes, then after 300 minutes
the new data will continue to be plotted, but the plot will start scrolling to the left.
That is, the current data will always be at the rightmost position of the graph. Each
time a new point comes on at the right, the graph shifts to the left by one pixel and
the leftmost point is deleted. In this way the last 300 minutes are always displayed.
So after the graph reaches the 300-minute mark, it will plot the current data at the
rightmost part of the graph but the Elapsed Time clock will continue past 300
minutes.

The X-Axis Settings has a Scrolling option. If Scrolling is not checked, then the
Real-Time Graph will be one page. If scrolling is enabled, you will have multiple
pages, and you can select the minutes per page.

If scrolling is enabled, a scrollbar will appear at the bottom of the graph. Only one
page will be displayed at a time. The total length of the graph will still be the same
as the Duration. Once the plot has reached the rightmost position you will need to
use the scrollbar at the bottom to move the graph to the left so that you can see the
latest data. In other words, the current value for Elapsed Time must appear on the
X-axis in order to see the latest point being plotted.

The advantage of using multiple pages (scrolling) is that you can look at current
data or you can easily scroll back to look at previously plotted data. The number
of data points that can be stored depends on the amount of memory available on
your computer. Most modern computers can save many hours of data in the Real-
Time Graph.

When using X-Axis Settings, certain combinations of settings are incompatible and
may result in an unusual looking graph or graph scale. If this occurs, simply do X-
Axis Settings again and change settings for update interval or for some other unit.

Occasionally the chart may become scrunched to the left with all of the time axis
values located under the vertical Y-axis. If this occurs, simply grab the leftmost
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side of the chart area with the mouse pointer and move it one pixel to the right or
left. This action should expand the chart to a normal view.

Each channel may be plotted in a different color on the graph. There are several
ways to change the color of a channel. You may select or change graph colors
with the Color feature described below, or with the Properties feature, or by
opening the Palette Bar under Tools and dragging a color to the line that you wish
to change.

Another legend identifying the color for each input may be selected by right
clicking within the graph area and selecting Legend Box. The legend box features
may be edited by right clicking in the legend box. These features include Hide,
Autosize, Font, Fixed, Floating, and position relative to the chart — left, top, right,
or bottom.

Touching the mouse pointer to any line being plotted will pop up a box with the
channel ID and the temperature reading. This is a very useful feature to quickly
identify which plot is which. If you wish to change the color of this line, simply
right click when you see the pop up box and select a new color by clicking on one
of those colors displayed.

You can easily change the background color of the graph or of the graph border by
positioning the mouse pointer in the desired area and right clicking to open a view
of the palette, then click on a new color to select.

A toolbar at the top of the graph provides the following functions:

Save Chart -- this saves the current chart (you must give it a filename and you may
select file type including ChartFx files, Metafiles and Bitmap files.)

Copy to Clipboard -- copies the current chart to the clipboard

Gallery -- used to select the style of the chart. The line chart is most useful.

Color -- The default color is shown in the rectangular box at the bottom of this
icon. To change the default color, click on the icon and select a different color.
This icon is used to change the color of the graph outline, the graph background or
to change the color of an individual line being plotted. To use this feature, click on
the icon with the left mouse button and hold down on the button. Drag the pointer
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of the paintbrush to the item that you wish to change color of and release the
mouse button.

You may also change the color of a line by positioning the mouse pointer on the
line, then right click to open a window where you may select a different color.

Vertical Grid -- toggles the vertical grid

Horizontal Grid -- toggles the horizontal grid

Data Viewer -- clicking on this icon opens or closes the Data Viewer. The Data
Viewer is a very useful feature. It lists the temperature values for each plotted
point. Note that the data editor has scroll bars at the right and bottom sides of the
window for the purpose of moving about within the Data Viewer. Note also that
the border between the Data Viewer and the Real-Time Graph is moveable
vertically. To move this border, position the mouse pointer at this interface line (a
double ended arrow will pop up) and then click and drag the line to change the size
of the Data Viewer window.

Properties -- opens a series of windows for adjusting properties of the Real-Time
Graph. Note that each window has a help feature with further information
applicable to that window by clicking on Help at the lower right. Whenever any
graph property is changed, it is saved as a default and it will stay that way until it is
changed again.

The General tab can be used to select the color for the background of the graph and
the color for the border surrounding the graph window. A graph title may also be
inserted or edited from this window.

The Series tab may be used to select line style, color and weight. Also markers for
the plotted points may be selected.

The Axes tab may be used to select properties of the graph axes. The minimum
and maximum values for the Y-axis may be selected with details. The values for
the X-axis are not enabled in this window; rather they are selected with Adjust
Chart.

Note: The ChartFx Properties dialog may be opened by positioning the mouse
pointer in any region of the graph screen and double clicking with the left mouse
button.
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3D/2D -- toggles between 3D and 2D mode
Rotate -- not functional
Z Clustered -- not functional

Zoom -- this is a very useful feature. Zoom can be turned on or off. When turned
on, the feature is used to quickly and easily change the scaling of the X and Y axes.
The mouse pointer is used to select a rectangular area within some portion of the
body of the graph. The portion of the graph within this rectangle will then be
redrawn full size. First, the mouse pointer is positioned at the upper left corner of
the desired rectangle and the left mouse button is pressed down to select the
starting point for the rectangle. Then the mouse is moved to create the rectangle,
which will enclose the portion of the graph to be redrawn when the mouse button is
released. Note that a zoomed graph can be "rezoomed" over and over to keep
changing the scale. However the graph can only be zoomed in. To zoom back out
to the original "unzoomed" state, simply click again on the Zoom icon of the
toolbar. Note also that a zoomed graph has a scroll bar at the bottom for moving
the graph horizontally, and a scrollbar at the right for moving the graph vertically.

Print Preview -- this feature is self-explanatory

Print -- clicking on the printer icon will open the Print setup dialog. This allows
the user to select the printer, the printer preferences and the page selection. Note
that the “Pages” section of the Page Range defaults to “1-65535.” This does not
mean that there are 65,535 pages — it is standard behavior of the Windows XP print
dialog.

Tools -- this icon is at the rightmost end of the toolbar. It is used to toggle the

Graph Legend, the Data Editor, the Toolbar, and the Palette Bar (used to select the
background colors or change the colors of individual lines on the graph. Just click
on a color square and drag it to the graph body or the graph border or a line on the

graph).

Note that whenever the mouse pointer is positioned within the body of the graph, a
right click of the mouse button will pop up a box which will enable toggling the
Toolbar, the Data Editor, or the Legend Box. Also selections may be made for
adding or Editing a graph title, Font, and Chart Properties.
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Note also that any border of the graph may be repositioned by grabbing the border
with a left click of the mouse pointer (a double ended arrow will appear) and
repositioning, then releasing the mouse button. Normally the right side of the
graph window is the only one that may ever need to be repositioned.

TROUBLESHOOTING PROCEDURES

If your hardware is connected to the proper COM Port and you are not getting
readings, go to the Device Status Window with View > Device Status. It errors
are reported here, check the serial cable, make sure the hardware has power (red
LED is ON) and make sure the instrument has signed on, (green LED is ON). The
serial port on the computer must have DTR high and RTS low.

If COM1 is not working or not available, you may select a different COM Port in
PinPoint Settings. And you can try operating at a slower baud rate. Open the
Workspace and double click on Hardware 0. Select the desired Baud Rate and
click OK. If a Workspace is not loaded, click File >Open - and select a *.ppw
file and open it. If there are no *.ppw files you may create one with
File>New->Workspace.

Note: The important files for your particular instrument are in the folder with the
same name as the serial number of your instrument. They will appear on your hard
drive at C:\Program Files\GEC\PinPoint\<your serial number>. Should these files
become corrupted while running PPM, they can be restored by running the
hardware install.

The *.ppc contains the configuration and other necessary information for your
particular instrument. This is the only file that is needed to run PPM.

The *.ppw file contains the aliases for the inputs, the default units for each input,
and a list of files to be loaded on program startup.

The *.ppi file contains the configuration of the main input screen, which channels
are selected for plotting, and the scale, units, update interval, etc for the Real-Time
Graph.

The *.ppi.cht file saves any custom settings you have created for the Real-time
Graph such as background colors, line style and width, etc. It will be accessed
automatically whenever an existing *.ppi is loaded.
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If you are having problems getting the program to run correctly, make sure the
correct *.ppc is in the correct path. To check or change this, do
Application=>Options, or run PinPoint Settings. If you change the configuration
file or the path you must leave the program and restart.

Note that the Tools = Options window has a box for Workspace Reload on
Startup. The Workspace contains the channel aliases and the default units. The
Workspace is normally reloaded on startup unless this box becomes unchecked due
to a program crash. If this happens, simply check the box, click Ok, leave the
program, and restart PPM. Or run PinPoint Settings and click Load Last
Workspace.

If there are no files listed in the Workspace view, you can load a *.ppw file with
File >Open. If you wish to create a Real-Time Report with different aliases or
different default units, simply edit the aliases and/or the units and run
Document->Save Workspace. Give the edited view a unique name. It will be a
Workspace file, *.ppw.

If you wish to start PPM from scratch with only a *.ppc then do the following
steps:

1. Close the Workspace with File > Close Workspace

2. Designate the configuration file (*.ppc) with Application - Options or with
PinPoint Settings.

3. Create a new Workspace (*.ppw) with the leftmost icon on the main toolbar, or
with File->New—->Workspace.

4. Create a new Input file (*.ppi) with the second icon on the main toolbar or with
File->New-> Input Monitor
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PLOTTING FROM A PPM DATABASE WITH PINPOINT VIEWER

Pinpoint Viewer is a standalone program which can be used to look at plots from
*.ppd log files created by Pinpoint Monitor. The PinPoint Viewer can be utilized
whether or not you are running PPM. It is used to plot data from previously logged
databases or even a database that is currently being logged to by PPM. And
multiple copies of the PinPoint Viewer may be started simultaneously, in the event
you wish to plot from more than one database without closing existing plots.

PinPoint Viewer supports *.ppd log files with instantaneous readings as well as
those that include values for average, standard deviation, max, min, or spread.

To use PinPoint Viewer, start the program, then click File >Open. Then double
click on the desired filename. Alternatively you may click on a recent file if that is
listed. This will pop up a dialog window that lists the channels that are in that
database. Click those channels that you wish to plot. Adjust the X-axis and Y-axis
units if desired. The start and end times are those that are at the beginning and end
of the logged database. Adjust these times if you do not want to plot the entire log.
If your PPM database (*.ppd) contains readings with more that one type of units
(such as temperature and relative humidity), you must select the units you wish to
plot. PPV can only plot one set of units on the Y-Axis at a given time. If you wish
to view data with more than one type of units, you may run multiple versions of
PPV simultaneously.

Click Ok to plot. Then click the boxes at the left to turn on or off the individual
channels. Touch the mouse pointer to a plotted line for more information. Right
click on any line to change its color.

Note that the filename and date and start time and end time of the plot are shown
above the graph. Double click within the chart area to edit ChartFx Properties.
Choose GEC Palette if available.

Click on the Data Viewer in the toolbar above the chart. This will display a list of
the times and temperature values.

All of the chart features in PinPoint Monitor (except for X-Axis Settings) are
available in PinPoint Viewer.
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If you have more time values than horizontal pixels, you will not see every data
point in the log, although all points will be loaded in memory. To look at more
points in a particular region of the graph, use the zoom feature from the toolbar
above the graph. Click the magnifying glass to turn on the zoom feature. Then
position the mouse pointer in the upper left of the region of the graph that you wish
to zoom. Hold down the left mouse button and select the region you wish to zoom
by removing the pointer to the lower right of this region. Release the mouse button
and the zoomed plot appears. Note that you will have a scrollbar for both the
horizontal and vertical axis. This will let you look at other parts of the graph with
the zoomed scaling. Click the magnifying glass to turn off zoom and go back to
the original graph.

To create another plot from the same or another database, just run File >Open and
double click on a database filename (*.ppd). If you have zoom enabled and then
load another database, the axis scaling from the previous plot will be there. In this
instance, turn off the zoom to see all of the data for the new plot.

And you may use Pinpoint Viewer to Export data to other formats such as Excel
spreadsheets or text files. Just run File - Export and open the ppd file from which
you wish to export. This will open a window in which you will select the channels
for which you wish to export data. The window’s title bar will show the number of
entries for this particular log. Click in the box at the top of the window to select or
deselect all channels. If you do not wish to export all channels, click on those you
want to export.

The export will retrieve every data point logged for the time period within the Start
Time and End Time. Note that the beginning and end time of the log session are
automatically inserted. If you do not wish to export all the data, you may edit the
Start Time and or the End Time before exporting. If you wish to export all the
data, simply make sure that the Start Time is less than or equal to the begin time of
the log and that the End Time is equal to or greater than the end time of the log.

Note that you may edit the Data Table name if you wish, up to a maximum of 32
characters. Valid characters include only letters and numerals. Or you may leave
the name of the Data Table blank.

You may select the type of file to export to, including a spreadsheet file, HTML
document, or text file.
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Under Path, you must enter a filename to export the data to. The export will have a
time stamp in the format Month/Date/Year HH:MM:SS. Further, you may select
an additional column of elapsed time starting with O for the first data point. Units
for the elapsed time may also be selected. And if you do not want all the readings,
you may enter an integer number in the Filter. Once all selections have been made,
click Ok and the export will begin. An hourglass will appear during the export
process.

Sometimes when exporting to Excel, you may get the message: Can't Update.
Database or object is read-only. If you get this message, then usually it will work
correctly if you try it a second time.

The message: Can't Update. Database or object is read-only sometimes occurs
when the ppd file is saved in a path that is over 64 characters in length. It only
appears intermittently. In order to avoid this error, try to keep path names to less
than 64 characters. (For example, “C:\data\filename.ppd” instead of
“C:\data\folder\second folder\third folder\fourth folder\fifth folder\filename.ppd™)

Keep in mind that path names to My Documents or the Desktop are longer than
“My Documents\File name” or “Desktop\File name”. The real path is
“C:\Documents and Settings\<user>\My Documents\File name.ppd.”

Note that the upon opening a standard Excel spreadsheet, the time stamp in the first
column will appear as MM:DD:YY. The seconds will appear to be missing. This
behavior is standard Excel behavior. The HH:MM:SS units are there, but in order
for them to appear, first the column must be reformatted with

Format-> Cells->Number->Custom. Under Type, pick m/d/yyyy h:mm. Then add
:ss and click Ok.

USING CUSTOM THERMOCOUPLE COEFFICIENTS WITH TCCONFIG
Now users of GEC precision thermocouple scanners can easily input custom
coefficients for calibrated thermocouple wire into a configuration file for their
instrument by means of a new software application called TCConfig.

When using custom calibrations, the measurement accuracy of the system will be

limited by the accuracy of the wire calibration and the homogeneity of the
thermocouple wire. All other errors in GEC thermocouple scanners are minimal.
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Download an installation of TCConfig with instructions from the downloads page
at http://www.gecinstruments.com
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